Вопрос:

java.lang.LinkageError: javax.servlet.jsp.JspApplicationContext.getExpressionFactory

jsp tomcat servlets linkageerror

64510 просмотра

6 ответа

389 Репутация автора

Когда я пытаюсь запустить свое веб-приложение на Tomcat 7, я получаю следующее исключение:

exception

javax.servlet.ServletException: java.lang.LinkageError: loader constraint violation: when resolving interface method "javax.servlet.jsp.JspApplicationContext.getExpressionFactory()Ljavax/el/ExpressionFactory;
" the class loader (instance of org/apache/jasper/servlet/JasperLoader) of the current class, org/apache/jsp/index_jsp, and the class loader (instance of org/apache/catalina/loader/StandardClassLoader) for resolved class, javax/servlet/jsp/JspApplicationContext, 
have different Class objects for the type javax/el/ExpressionFactory used in the signature
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:343)
javax.servlet.http.HttpServlet.service(HttpServlet.java:722)

root cause

java.lang.LinkageError: loader constraint violation: when resolving interface method "javax.servlet.jsp.JspApplicationContext.getExpressionFactory()Ljavax/el/ExpressionFactory;" the class loader (instance of org/apache/jasper/servlet/JasperLoader) of the current class, org/apache/jsp/index_jsp, and the class loader (instance of org/apache/catalina/loader/StandardClassLoader) for resolved class, javax/servlet/jsp/JspApplicationContext, have different Class objects for the type javax/el/ExpressionFactory used in the signature
org.apache.jsp.index_jsp._jspInit(index_jsp.java:31)
org.apache.jasper.runtime.HttpJspBase.init(HttpJspBase.java:49)
org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:180)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:369)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
javax.servlet.http.HttpServlet.service(HttpServlet.java:722)

Кажется, что есть конфликт между двумя .jarбиблиотеками, но я не знаю, кто они. Как я могу их выяснить и решить?

Автор: Br3x Источник Размещён: 13.12.2011 09:42

Ответы (6)


2 плюса

3741 Репутация автора

Проверьте эту страницу

http://www.jarfinder.com/index.php/java/info/org.apache.jasper.runtime.HttpJspBase

Найдите, какие банки вы использовали в этом. Удалите одного, если найдете два. :)

Автор: Kris Размещён: 13.12.2011 10:57

55 плюса

880869 Репутация автора

Решение

Это произойдет , когда вы включаете сервер-специфические библиотеки другого сервера макияжем / версии в /WEB-INF/libвашей веб - приложения, такие как jsp-api.jar, el-api.jar, servlet-api.jarи т.д. Вы должны удалить их все. Не /WEB-INF/libдолжно содержать никаких специфичных для сервера библиотек. Они принадлежат конкретному серверу (он уже есть в Tomcat /lib).

Это, кстати, довольно распространенная ошибка новичка, когда они сталкиваются с ошибками компиляции в JSP / Servlet API в своем проекте IDE. Это должно было быть решено по-другому, а именно путем интеграции сервера в IDE и добавления сервера в качестве «целевого времени выполнения» в проект.

Смотрите также:

Автор: BalusC Размещён: 13.12.2011 12:04

16 плюса

674 Репутация автора

У вас есть два варианта для добавления ваших библиотек проектов, таких , как jsp-api.jar, el-api.jar, servlet-api.jarи т.д.:

  1. Добавьте эти библиотеки в качестве внешних jar в вашем Java Build Path;
  2. Добавьте их как зависимости maven, задав providedобласть действия для каждого из них, например:
<dependency>
    <groupId>javax.servlet.jsp</groupId>
    <artifactId>jsp-api</artifactId>
    <version>2.1</version>
    <scope>provided</scope>
</dependency>
Автор: vadim Размещён: 08.02.2013 03:10

2 плюса

45287 Репутация автора

Я застрял с этой ошибкой в ​​течение очень долгого времени, и эта тема сэкономила немало моего времени. Добавив некоторые исследования, которые я сделал, прежде чем решить эту проблему. Да, нам нужно удалить библиотеки, как jsp-api.jar, el-api.jar, servlet-api.jarиз /WEB-INF/libпапки. Но как?

В моем случае я использую Apache Ivy в качестве менеджера зависимостей и использую Spring MVC. Он загружает все зависимости вместе с библиотеками, упомянутыми выше. Во время выполнения эти конфликты с API, предоставляемыми библиотеками Tomcat. Простым решением было бы исключить эти jar-файлы из зависимостей или создать конфигурации и включить эти библиотеки только в конфигурацию времени компиляции. Что сработало для меня быстро, так это исключение этих библиотек.

    <dependency org="org.springframework" name="spring-webmvc"
        rev="4.0.4.RELEASE">
        <exclude org="javax.servlet" name="javax.servlet-api" />
        <exclude org="javax.servlet.jsp" name="jsp-api" />
        <exclude org="javax.el" name="javax.el-api" />
    </dependency>
Автор: Aniket Thakur Размещён: 10.06.2014 06:04

0 плюса

881 Репутация автора

Это странная ОШИБКА, которую я когда-либо получал

После повторного поиска я нашел это Причины и решение

Я использую Spring, поэтому в моих библиотеках @spring у меня уже есть банка

Servlet-api.jarили javax-servlet-api.jar jsp-api.jarилиjavax-servlet-jsp.jar

Но это несовместимо с моим сервером TOMCAT. Так что я просто удаляю эти два jar-файла из моего встроенного пути и сборки развертывания. Теперь я перехожу к моему «E: \ Locker \ Software \ apache-tomcat-6.0.44 \ lib», где находится мой сервер Tomcat. и добавить эти две банки в мой проект

servlet-api.jar
jsp-api.jar
Автор: Hasnain Ali Bohra Размещён: 01.07.2015 08:06

0 плюса

1 Репутация автора

В моем случае у меня была зависимость от tomcat, а также плагин tomcat, упомянутый в POM. Убрал зависимость, оставив там только плагин, и он заработал.

Автор: Yasser Khan Размещён: 11.08.2019 08:34
Вопросы из категории :
32x32