Вопрос:

невозможно установить Django 2.2.4 для python3.7.4 в Linux mint 19.1

python django pip pipenv

7 просмотра

1 ответ

1 Репутация автора

Я хочу установить Django Web Framework версии 2.2.4 в Linux. Я использую Linux Mint 19.1 с python2 (по умолчанию), python3.6.8 (по умолчанию) и python3.7.4 (sudo установлен из исходного кода).

Я использую команду 'pipenv --python3.7 install django == 2.2', но она не работает.

Я попробовал этот учебник, чтобы установить Django- ссылку на учебник YouTube

$ python3.7 -V

Python 3.7.4

$ pip3 -V

пип 19.2.1 из /usr/local/lib/python3.7/site-packages/pip (python 3.7)

~ dev / try_django $ pipenv --python3.7 установить django == 2.2.4

Использование: pipenv [OPTIONS] COMMAND [ARGS] ... Попробуйте "pipenv -h" для помощи.

Ошибка: нет такой опции: --python3.7

Автор: Ankur Kumar Источник Размещён: 11.08.2019 07:16

Ответы (1)


0 плюса

838 Репутация автора

Если вы запустите pipenv -h, pipenv распечатает страницу справки. Возле дна будет несколько примеров. Среди этих образцов есть:

Usage Examples:
   Create a new project using Python 3.7, specifically:
   $ pipenv --python 3.7

Как видите, вам не хватает пробела между --pythonи 3.7частями.

Автор: Kendas Размещён: 11.08.2019 07:31
Вопросы из категории :
32x32