Вопрос:

Используя tcp порт "9300" в файле application.properties, но по-прежнему отображается сообщение "Ни один из настроенных узлов не доступен"

spring-boot elasticsearch

10 просмотра

1 ответ

4 Репутация автора

Ошибка:

failed to load elasticsearch nodes : org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{uyXiOMnyRpyTSXqUoNxTyg}{localhost}{127.0.0.1:9300}]

Версии:

Версия Spring-Boot: 2.1.6 и версия Elasticsearch: 7.3.0

Вот мой файлasticsearch.yml:

# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
#       Before you set out to tweak and tune the configuration, make sure you
#       understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster.
#
# Please consult the documentation for further information on configuration options:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
cluster.name: elastic
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
#node.name: node-1
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
path.data: D:\JEE_Projects\spring\Spring_WorkSpace\spring-boot-with-mongodb
#
# Path to log files:
#
#path.logs: /path/to/logs
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
#network.host: 192.168.0.1
#
# Set a custom port for HTTP:
# http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when this node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
#discovery.seed_hosts: ["host1", "host2"]
#
# Bootstrap the cluster using an initial set of master-eligible nodes:
#
#cluster.initial_master_nodes: ["node-1", "node-2"]
#
# For more information, consult the discovery and cluster formation module documentation.
#
# ---------------------------------- Gateway -----------------------------------
#
# Block initial recovery after a full cluster restart until N nodes are started:
#
#gateway.recover_after_nodes: 3
#
# For more information, consult the gateway module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true

Вот мой файл application.properties:

#Local MongoDB config
spring.data.mongodb.uri=mongodb://localhost:27017/newtest


# App config
server.port=8080
spring.application.name=BootMongo
server.address=localhost

# elastic search

spring.data.elasticsearch.cluster-name=elastic

#spring.main.allow-bean-definition-overriding=true

#spring.data.elasticsearch.repositories.enabled = true
spring.data.elasticsearch.cluster-nodes =localhost:9300

Я перезапустил приложение, перезапустилasticsearch.bat и даже перезапустил весь компьютер, но ничего не работает.

Более того, я думал, что некоторые другие приложения заняли бы порт, но он был занят самим эластичным поиском. (Я набрал «localhost: 9300» в браузере, и он отвечал как «Это не порт HTTP»).

Автор: prajjwal gupta Источник Размещён: 10.08.2019 07:55

Ответы (1)


0 плюса

39 Репутация автора

Я предполагаю, что 'cluster-name =astic' может быть неправильным. Вы уверены, что эластичные бега с таким именем кластера?

Автор: Dario Размещён: 11.08.2019 08:31
Вопросы из категории :
32x32