Вопрос:

Могу ли я обновить версию MQ до 9.0, продолжая использовать WAS 8.5.5?

mq was

10 просмотра

1 ответ

154 Репутация автора

У моего работодателя есть приложение, работающее на WAS-сервере 8.5.5. Он использует клиентский адаптер MQ для подключения к настройке MQ в версии 7. Теперь мой работодатель выполняет обновление до версии 9 в MQ, но хочет сохранить сервер WAS на 8.5.5. Это возможно? В одной из статей IBM я увидел следующее:

Адаптер ресурсов IBM MQ Версии 9.0 нельзя развернуть в более ранних версиях WebSphere Application Server, поскольку эти версии не сертифицированы для Java ™ EE 7.

Автор: pna Источник Размещён: 12.06.2019 06:49

Ответы (1)


0 плюса

86 Репутация автора

Если ваш вопрос относится к традиционным WAS (а не к профилю Liberty), то ответ - да.

tWAS связывает уровень адаптера ресурсов MQ , и этот связанный RA наследует жизненный цикл поддержки сервера приложений. [Эта поддержка не распространяется на другие версии адаптера ресурсов MQ, которые были вручную применены к установке tWAS, поэтому обычно рекомендуется использовать связанный RA.]

Любой поддерживаемый клиент MQ может связываться с любым поддерживаемым администратором очередей MQ , поскольку любая из сторон будет согласовывать версию используемых потоков связи MQ вплоть до взаимно подходящего уровня. Это означает, что адаптер ресурсов MQ 7.1 может взаимодействовать с администратором очередей версии 9.0, хотя, конечно, любые подключения, которые устанавливает этот клиент, не будут иметь права использовать функциональные возможности, добавленные в продукт после 7.1.

Автор: ChrisL Размещён: 12.06.2019 04:23
Вопросы из категории :
32x32