Вопрос:

VS2017 Blank Sign In Screen

visual-studio visual-studio-2017 msdn

1749 просмотра

4 ответа

61 Репутация автора

I have a unique issue with my installation of Visual Studio 2017 where the sign in dialog is blank, and no matter how long I wait it never seems to allow me to log in.

I have tried changing the default browser to Chrome, Edge and IE just in case it was using that under the hood for rendering this page. Prior to that I had an issue with the Virtual Machine running the IDE which required me to re-register *.VBS associations to complete the install, that has been resolved and the install has passed.

I am now just left with the sign in issue as shown below:

Has anyone had this before / know of a work around here? I have been looking around on Google for similar issues but to no avail.

Any help here would be appreciated.

Thanks!

Автор: Richard Niemand Источник Размещён: 09.01.2018 04:39

Ответы (4)


5 плюса

51 Репутация автора

I think I found something...

If you go to Help tab and click on Send Feedback >> Report a Problem, a Developer Community forum page will pop-up.

In this page, you will see a sign-in link very much like the one in Visual Studio.

That particular link works, so if you log in to it, then exit the Developer Community Forum, you will have successfully logged into Visual Studio.

Hope this helps.

Автор: Eduardo Zavala Размещён: 08.02.2018 06:02

2 плюса

42 Репутация автора

I had the same issues. The problem was with Internet Explorer. My computer has Internet Explorer 8. Please follow the steps below to fix the issue.

  1. Install Internet Explorer 11 - you can download it from the Microsoft site.

  2. Restart the computer

  3. Relaunch Visual Studio
  4. Now sign in.
  5. No blank screen will be displayed.
Автор: Safeer MP Размещён: 06.03.2018 01:53

9 плюса

91 Репутация автора

I just encountered this issue myself on Visual Studio 2017 (30-day evaluation expired too so Eduardo Zavala's suggestion isn't possible). The cause is that I have Internet Explorer 11 installed and set to be extremely restrictive security wise. For example, it will not follow a redirect if a webpage tells it to. It also has JavaScript disabled. Apparently, Visual Studio uses Internet Explorer 11 (or at least "Internet Options" rules) for this login page instead of the default browser (e.g. Microsoft Edge) and its settings.

  1. Start Internet Explorer 11.
  2. Click on the gear icon in the upper right corner.
  3. Click "Internet Options."
  4. Click on the "Security" tab.
  5. Click "Default level" button.
  6. Click "Apply."
  7. Click "OK."

Run Visual Studio 2017 again and sign in.

Set Internet Explorer 11 settings back to how you prefer them.

All should be well in both programs now (VS17 authorized and IE11 restrictive).

Автор: Lee Glasser Размещён: 25.03.2018 06:15

0 плюса

51 Репутация автора

Just change your default Internet browser to Internet Explorer.

Автор: AGR Размещён: 14.05.2019 07:58
Вопросы из категории :
32x32