Вопрос:

Использование Parsoid с расширением Auth Remoteuser на XAMPP (Windows)

mediawiki mediawiki-api mediawiki-extensions visual-editor parsoid

373 просмотра

1 ответ

46 Репутация автора

Я искал последнюю неделю, пытаясь найти ответ о том, как использовать расширения Visual Editor / Parsoid и Auth Remoteuser вместе.

Я получаю следующую ошибку при попытке создать / изменить страницу:

Error loading data from server: apierror-visualeditor-docserver-http: HTTP 500. Would you like to retry?

Текущая среда:

  • ОС: Windows Server 2012 RT
  • XAMPP: v3.2.2
  • PHP: v7.1.12
  • SQL: MariaDB 10.1.29
  • Apache: v2.4
  • MediaWiki: 1.30.0

LocalSettings.php

$wgEnableWriteAPI = true;

wfLoadExtension( 'VisualEditor' );

$wgDefaultUserOptions['visualeditor-enable'] = 1;
$wgDefaultUserOptions['visualeditor-editor'] = "visualeditor";
$wgHiddenPrefs[] = 'visualeditor-enable';

$wgVirtualRestConfig['modules']['parsoid'] = array(
    'url' => 'http://localhost:8000',
    'domain' => 'localhost',
);

config.yaml

mwApis:
  uri: 'http://localhost/api.php'
  domain: 'localhost'

httpd.conf

<Directory "D:/Wiki/htdocs">
    Options None 
    AllowOverride All 
    Order allow,deny 
    Allow from all 

    AuthType SSPI 
    SSPIAuth On 
    SSPIAuthoritative On 
    SSPIOfferBasic On 
    SSPIOmitDomain On 
    Require valid-user
</Directory>

Когда я захожу на сервер Parsoid со своего компьютера, он работает. http: //xx.xxx.xx.xx: 8000 . Если я отключу расширение Auth Remoteuser, то Visual Editor работает нормально.

Я попытался переслать файлы cookie, как указано в документации Parsoid, и они не работают. Эта вики не является частной.

Когда я добавляю следующее в httpd.conf, работает Visual Editor:

Allow from 127.0.0.1
Satisfy Any

Единственная проблема заключается в том, что он не входит в систему автоматически, используя учетные данные Windows.

Автор: Kumaran S Источник Размещён: 05.01.2018 07:59

Ответы (1)


0 плюса

1 Репутация автора

может быть немного поздно, но у меня была та же проблема. Похоже, это решает это. Просто прокомментируйте устаревший параметр в php.ini error_reporting = E_ALL ->; error_reporting = E_ALL

Ключ 'error_reporting' в разделе '[PHP]' вызывает проблему.

Автор: Semenov Andrii Размещён: 18.05.2019 08:05
Вопросы из категории :
32x32