Вопрос:

Android Studio 3.0.1 Error: Gradle project sync failed. Basic functionality (e.g. editing, debugging) will not work properly

android android-studio gradle android-gradle

35018 просмотра

10 ответа

450 Репутация автора

I've installed Android studio 3.0.1 and tried to build very first app with choosing an empty activity, but I've get the message:

Gradle project sync failed. Basic functionality (e.g. editing, debugging) will not work properly

and error message like this:

Unable to resolve dependency for ':app@releaseUnitTest/compileClasspath': Could not resolve com.android.support:appcompat-v7:26.1.0. Could not resolve com.android.support:appcompat-v7:26.1.0. Required by: project :app Could not resolve com.android.support:appcompat-v7:26.1.0. Could not parse POM https://dl.google.com/dl/android/maven2/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom Already seen doctype.

введите описание изображения здесь

введите описание изображения здесь

and this is first part of log message is:

2018-01-03 11:11:12,671 [d thread 8] WARN - ect.sync.idea.ProjectSetUpTask - Already seen doctype. Consult IDE log for more details (Help | Show Log) 2018-01-03 11:11:12,671 [d thread 8] INFO - e.project.sync.GradleSyncState - Gradle sync failed: Already seen doctype.

I've tried some suggested solution like changing gradle version, update Kotlin plugin(!) and so, but they didn't work.

Any solution?

Автор: pooria haddad Источник Размещён: 04.01.2018 02:02

Ответы (10)


0 плюса

46 Репутация автора

У меня была та же проблема, я загрузил версию Gradle и использовал ее как локальный дистрибутив. Настройки / Build, .. / Gradle / Использовать локальное распространение. В противном случае вам придется переустановить все программное обеспечение.

Автор: Master49 Размещён: 04.01.2018 03:37

6 плюса

77 Репутация автора

This problem occurs when the Build Tools Version is not set for the project. You just set the build tools version by following this process...

By opening your project structure [File->Project Structure] and selecting the Build Tools Version from app's property tab in Modules section.

This will add build tools version to your gradle file (Module:app) and re-sync the project.

Автор: Mridul Das Размещён: 05.01.2018 07:54

3 плюса

450 Репутация автора

Решение

The problem caused by my connection. I needed to set proxy to download some components.

Автор: pooria haddad Размещён: 07.01.2018 08:20

2 плюса

418 Репутация автора

Ошибка происходит при колебании сети. Поэтому сначала убедитесь, что ваше соединение стабильно. Кроме того, если вы используете какой-либо VPN, проверьте, gradle.propertiesправильно ли настроен ваш .

Правильная форма подключения VPN gradle.propertiesвыглядит следующим образом:

systemProp.http.proxyHost=127.0.0.1
systemProp.http.proxyPort=8080
systemProp.https.proxyHost=127.0.0.1
systemProp.https.proxyPort=8080

Мое соединение с хостом есть 127.0.0.1, а его порт 8080для обоих httpи https.

Еще одна вещь, обязательно добавьте https(это обязательно).

Автор: Esmaeil MIRZAEE Размещён: 11.02.2018 10:01

1 плюс

16 Репутация автора

У меня была такая же проблема, когда я обновлялся до Android Studio 3.1.2, и проблема, которую я использовал с предыдущим JDK, который я установил до 5 лет назад.

Шаги:-

Go to File -> Project Structures -> SDK Location -> JDK Location -> check the 
Option Use embedded JDK (recommended).
Автор: Mohammed_AlRawhani Размещён: 26.05.2018 08:26

1 плюс

11 Репутация автора

Эта проблема возникает, когда версия Build Tools не установлена ​​для проекта. Вы просто устанавливаете версию инструментов сборки, следуя этому процессу ...

Открыв структуру вашего проекта [Файл-> Структура проекта] и выбрав версию инструментов сборки на вкладке свойств приложения в разделе «Модули».

Это добавит версию инструментов сборки в ваш файл Gradle (Module: app) и повторно синхронизирует проект.

Проблема вызвана моим подключением. Мне нужно было установить прокси для загрузки некоторых компонентов

Автор: Ja Mal Ch Размещён: 30.07.2018 03:30

0 плюса

1 Репутация автора

Решение довольно простое. Это потому, что «compileSdkVersion», который вы используете в вашем build.gradle (Module: app), выше, чем SDK, установленный в вашей студии Android. Что теперь делать? Просто зайдите в SDK Manager и загрузите уровень API выше или равный вашему «compileSdkVersion», и все готово

Автор: Moreno JN BAPTISTE Размещён: 08.08.2018 01:54

0 плюса

73 Репутация автора

Для меня это было исправлено следующим ответом Мридул Дас, а затем перезапустить студии.

Автор: Simon Размещён: 20.08.2018 08:55

0 плюса

1 Репутация автора

Посмотрите на манифест, может там что-то пошло не так. В моем случае у меня был этот ярлык <uses-sdk android: minSdkVersion = "7" android: targetSdkVersion = "15" />, который был из примера. Тогда ошибка отображается, и корреспондент теперь обновляется<uses-sdk android: minSdkVersion = "15" android: targetSdkVersion = "27" />

Автор: user3525542 Размещён: 21.10.2018 04:03

0 плюса

1 Репутация автора

Ошибка синхронизации проекта Gradle. Основные функции (например, редактирование, отладка) не будут работать должным образом

Перейдите в сценарии gradle -> build gradle (app) -> внесли следующие изменения:

введите описание изображения здесь

Наконец-то это работает.

Автор: Saurabh Gond Размещён: 22.05.2019 05:35
Вопросы из категории :
32x32