Вопрос:

Нужна помощь в установке mcrypt для среды php dev на Mac High Sierra

php macos mcrypt macos-high-sierra

2402 просмотра

1 ответ

11 Репутация автора

Я провел большую часть дня, исследуя это. Вчера я обновил свой ноутбук Mac до High Sierra. Это обновило приложение Server, которое запускает мою среду разработки. Среда в порядке, за исключением того, что я не могу установить mcrypt. Mac HS поставляется с PHP 5.6.30, и я прошел через эти шаги ( https://michaelgracie.com/2016/09/plugging-mcrypt-into-php-on-macos-sierra-10-12/ ) несколько раз , Я добираюсь до шага, где я бегу

MACOSX_DEPLOYMENT_TARGET=10.13 CFLAGS='-O3 -fno-common -arch i386 -arch x86_64' LDFLAGS='-O3 -arch i386 -arch x86_64' CXXFLAGS='-O3 -fno-common -arch i386 -arch x86_64' ./configure --with-php-config=/usr/bin/php-config

Но это возвращает:

-bash: ./configure: нет такого файла или каталога

Любая помощь будет принята с благодарностью.

Автор: Jeff T Источник Размещён: 08.11.2017 11:59

Ответы (1)


1 плюс

84 Репутация автора

Решение

У меня та же проблема, что и у вас, так как я вчера обновился до высокой Сьерры и испортил свою среду разработки. Я наконец узнал, что High Sierra уже поставляется с Php71, поэтому тот, который я уже установил, был переопределен, поэтому я сделал следующее:

for i in $(brew list | grep php); do brew uninstall $i; done

он получил мой PHP теперь работает все, что я сделал, это установить

brew install php71-mcrypt php71-imagick

бум для меня сработал как обаяние, надеюсь, это поможет вам или кому-то еще

Все это было из терминала

эта ссылка также может вам помочь

https://getgrav.org/blog/macos-sierra-apache-multiple-php-versions

Автор: Gustavo A Garcia Размещён: 10.11.2017 07:40
Вопросы из категории :
32x32