Etheruem: ошибка Pyethereum

setuptools ethereum

160 просмотра

1 ответ

После установки pyethereum я получаю следующую ошибку с просьбой обновить мои setuptools. Я обновил setuptools, но, похоже, моя система не может его распознать.

Вот ошибка, которую я получаю:

error: Setup script exited with Your setuptools version (1.1.6) is too old to
correctly install this package. Please upgrade to a newer version (>= 3.3).
Автор: Mover Источник Размещён: 08.11.2019 11:32

Ответы (1)


2 плюса

Решение

Попробуйте запустить это:

sudo easy_install -U setuptools

В моем случае это привело меня к setuptools версии 25.4.0 для Python версии 2.7 на моем Mac, что я проверил, выполнив это:

sudo easy_install --version

setuptools 25.4.0 from /Library/Python/2.7/site-packages/setuptools-25.4.0-py2.7.egg (Python 2.7)
Автор: warmbeach Размещён: 20.08.2016 06:02
Вопросы из категории :
32x32