Сервисы Google; com.google.gms: google-services: 2.1.2; не удалось разрешить службы измерения

android-studio gradle google-play-services

1767 просмотра

1 ответ

Просто пытаюсь обновить Google Play до последней версии 9.4.0. Если я оставлю classpath в gradle уровня приложения до версии 2.1.2, которая, кажется, является последней версией по состоянию на 03 июня, ссылка , я получаю ошибку, которую не удалось устранить:

Ошибка: не удалось разрешить: com.google.android.gms: play-services-measure: 9.4.0 Установить репозиторий и синхронизировать проект

Я уже обновил свои пакеты в менеджере SDK. Если я оставлю classpath как 3.0.0, который был релизом мая, то все будет в порядке. Любая идея о том, почему я получаю такую ​​ошибку с classpath версии 2.1.2? см. ниже мои файлы Gradle. Версия Android Studio: 2.1.3. Ценю любую помощь.

Уровень проекта build.gradle:

buildscript {
    repositories {
        jcenter()
        mavenLocal()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.1.3'
        classpath 'com.google.gms:google-services:2.1.2'
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
        mavenLocal()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

Уровень приложения build.gradle:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 24
    buildToolsVersion "24.0.0"

    defaultConfig {
        applicationId "com.example.main.projectone"
        minSdkVersion 18
        targetSdkVersion 24
        versionCode 1
        versionName "1.0"
        multiDexEnabled true
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'


    compile('com.facebook.android:facebook-android-sdk:4.7.0') {
        exclude module: 'bolts-android'
    }

    compile 'com.android.support:appcompat-v7:24.0.0'

    compile 'com.android.support:design:24.0.0'
    compile 'com.parse:parse-android:1.13.0'
    compile 'com.github.bumptech.glide:glide:3.7.0'
    compile 'com.github.bumptech.glide:okhttp3-integration:1.4.0@aar'
    compile 'com.squareup.okhttp3:okhttp:3.3.1'
    compile 'com.android.support:cardview-v7:24.0.0'
    compile 'com.android.support:support-v4:24.0.0'
    compile 'com.android.support:multidex:1.0.1'
    compile 'com.fasterxml.jackson.core:jackson-annotations:2.8.1'
    compile 'de.hdodenhof:circleimageview:2.1.0'
    compile 'com.android.support:recyclerview-v7:24.0.0'
    compile 'com.firebase:geofire-android:2.0.0'

    compile 'com.google.android.gms:play-services:9.4.0'
    compile 'com.google.firebase:firebase-auth:9.4.0'
    compile 'com.google.firebase:firebase-storage:9.4.0'
}

apply plugin: 'com.google.gms.google-services'
Автор: TheeBen Источник Размещён: 08.11.2019 11:14

Ответы (1)


1 плюс

Решение

Поскольку вы используете версию 9.4.0, вы должны использовать плагин сервиса Google Play v 3.0.0:

buildscript {
    // ...
    dependencies {
        // ...
        classpath 'com.google.gms:google-services:3.0.0'
    }
}

Проверьте официальную документацию по настройке.

Автор: Gabriele Mariotti Размещён: 20.08.2016 12:28
Вопросы из категории :
32x32