ОШИБКА: при выполнении gem ... (Gem :: Package :: FormatError) метаданные пакета отсутствуют в profile.gem

ruby-on-rails ruby rubygems

512 просмотра

1 ответ

Я использую OS X El Capitan 10.11.6 Во-первых, у меня проблема с установкой модулей и я могу найти проблему после выполнения шага на этом сайте. Терминал разъясняет проблему, это было ruby ​​v 2.2.2 после того, как я установил его, я получаю новая проблема, когда я пытаюсь установить cocoapods

$ sudo gem install cocoapods

Password:

ERROR:  While executing gem ... (Gem::Package::FormatError)
package metadata is missing in profile.gem

Любая помощь могла бы быть полезна. Спасибо !

Автор: mandro 00 Источник Размещён: 08.11.2019 11:10

Ответы (1)


0 плюса

Я думаю, что вам может потребоваться удалить, а затем установить снова.

gem uninstall cocoapods

или же

sudo gem uninstall cocoapods

а потом

gem install cocoapods

или же

sudo gem install cocoapods

Почему вы используете sudo? Это обычно не обязательно. В другом посте stackoverflow упоминается об этом.

Автор: kcdragon Размещён: 20.08.2016 02:59
Вопросы из категории :
32x32