Ошибка: пожалуйста, исправьте конфликт версий, обновив версию плагина google-services

android android-studio android-gradle-plugin

2930 просмотра

2 ответа

Попытка реализовать уведомления GCM, получила ошибку конфликта

** Ошибка: сбой при выполнении задачи ': app: processDebugGoogleServices'.

Исправьте конфликт версий, либо обновив версию плагина google-services (информация о последней версии доступна по адресу https://bintray.com/android/android-tools/com.google.gms.google-services/ ). или обновите версию com.google.android.gms до 8.3.0. **

dependencies {
compile project(':viewPagerIndicator')
compile fileTree(dir: 'libs', include: ['*.jar'])
testCompile 'junit:junit:4.12'
compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.4'
compile 'com.android.support:appcompat-v7:24.2.0'
compile 'org.apache.httpcomponents:httpclient:4.5'
compile 'com.android.support:recyclerview-v7:24.2.0'
compile 'com.google.android.gms:play-services:9.4.0'
compile 'com.facebook.android:facebook-android-sdk:4.0.0'
compile 'com.koushikdutta.ion:ion:2.+'
compile 'com.github.bumptech.glide:glide:3.6.1'
compile 'com.android.support:multidex:1.0.0'
compile 'com.google.android.gms:play-services-ads:9.4.0'
compile 'com.google.android.gms:play-services-auth:9.4.0'
compile 'com.google.android.gms:play-services-gcm:9.4.0'
//classpath 'com.splunk:mint-gradle-android-plugin:5.1.0'
//  compile 'com.splunk:mint-android-sdk:5.1.0'
//compile 'com.splunk:mint-android-instrumentation-okhttp:5.1.0'
compile 'com.splunk.mint:mint:5.0.0'

           }
   apply plugin: 'com.google.gms.google-services'

Вот мое приложение Gradle

buildscript {
repositories {
    jcenter()
 maven{
url "https://mint.splunk.com/gradle/"
 }
}
dependencies {
    classpath 'com.android.tools.build:gradle:2.1.3'
    classpath 'com.google.gms:google-services:1.5.0-beta2'
    classpath 'com.android.tools.build:gradle:2.0.0-alpha6'

}
}
Автор: ahmad Источник Размещён: 08.11.2019 11:02

Ответы (2)


1 плюс

Поскольку вы используете v.9.4.0, вы должны использовать v.3.0.0 плагина google play services:

dependencies {
    classpath 'com.android.tools.build:gradle:2.1.3'
    classpath 'com.google.gms:google-services:3.0.0'
}
Автор: Gabriele Mariotti Размещён: 20.08.2016 12:33

0 плюса

Там должен быть более объяснительный журнал ошибок в вашем logcat. Он появляется перед этим сообщением об ошибке, о Error:Execution failed for task ':app:processDebugGoogleServicesкотором вы сообщили. Пожалуйста, опубликуйте полное сообщение об ошибке.

Кроме того, я вижу, что у вас есть две зависимости для gradle в вашем приложении gradle; это classpath 'com.android.tools.build:gradle:2.1.3'и это classpath 'com.android.tools.build:gradle:2.0.0-alpha6'. Я предлагаю оставить только classpath 'com.android.tools.build:gradle:2.1.3'и также добавить classpath 'com.google.gms:google-services:1.3.0-beta1'в этот gradle.

Проверьте ваш cradle-wrapper.properties, чтобы содержать distributionUrl=https\://services.gradle.org/distributions/gradle-2.8-all.zipили distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zipвместо этих альфа-релизов.

Если проблема все еще остается, пожалуйста, опубликуйте полное сообщение об ошибке (желательно весь журнал в вашем logcat), а также build-tools, targetdk и compileSdk версию вашего файла Gradle.

Автор: Merka Размещён: 20.08.2016 10:53
Вопросы из категории :
32x32