Не удалось установить хромдрайвер

node.js npm selenium-chromedriver npm-install slamdata

3743 просмотра

1 ответ

Я собираюсь установить slamdata на Debian Jessie, как описано здесь , но мне не удалось установить раздел npm, и он хотел установить chromedriver. Я даже попробовал зеркало хромедрайвера. Вот логи.

exec@mob-db1:/opt/slamdata$ npm install

npm WARN устарел npmconf@2.1.2: этот пакет был реинтегрирован в npm и теперь устарел по отношению к npm

chromedriver@2.23.1 install / opt / slamdata / node_modules / chromedriver узел install.js

Загрузка http://chromedriver.storage.googleapis.com/2.23/chromedriver_linux64.zip Сохранение в /tmp/chromedriver/chromedriver_linux64.zip Получение ... Установка ChromeDriver завершилась неудачно не определено

npm WARN необязательный Пропуск необязательной зависимости / chokidar / fsevents:

npm WARN notsup Несовместимо с вашей операционной системой или архитектурой: fsevents@1.0.14

нпм ERR! Linux 4.2.8-1-pve

нпм ERR! argv "/ usr / bin / nodejs" "/ usr / bin / npm" "установить"

нпм ERR! узел v6.4.0

нпм ERR! npm v3.10.6

нпм ERR! код ELIFECYCLE

нпм ERR! chromedriver@2.23.1 install: узел install.js

нпм ERR! Статус выхода 1

нпм ERR!

нпм ERR! Сбой на узле chromedriver@2.23.1 сценария установки install.js.

нпм ERR! Убедитесь, что у вас установлена ​​последняя версия node.js и npm.

нпм ERR! Если вы это сделаете, это, скорее всего, проблема с пакетом chromedriver,

нпм ERR! не с самой нпм.

нпм ERR! Скажите автору, что это не работает в вашей системе:

нпм ERR! узел install.js

нпм ERR! Вы можете получить информацию о том, как открыть вопрос для этого проекта, с помощью:

нпм ERR! Npm Bugs Хромированный драйвер

нпм ERR! Или, если это не доступно, вы можете получить их информацию через:

нпм ERR! владелец npm ls chromedriver

нпм ERR! Вероятно, есть дополнительные выходные данные регистрации.

нпм ERR! Пожалуйста, включите следующий файл с любым запросом поддержки:

нпм ERR! /opt/slamdata/npm-debug.log

exec@mob-db1:/opt/slamdata$ npm install chromedriver --chromedriver_cdnurl=http://npm.taobao.org/mirrors/chromedriver

npm WARN устарел npmconf@2.1.2: этот пакет был реинтегрирован в npm и теперь устарел по отношению к npm

chromedriver@2.23.1 install / opt / slamdata / node_modules / chromedriver узел install.js

Загрузка http://npm.taobao.org/mirrors/chromedriver/2.23/chromedriver_linux64.zip Сохранение в /tmp/chromedriver/chromedriver_linux64.zip Получение ... Сбой установки ChromeDriver не определен npm ПРЕДУПРЕЖДЕНИЕ необязательно Пропуск не удалось необязательной зависимости / chokidar / fsevents: npm WARN notsup Несовместимо с вашей операционной системой или архитектурой: fsevents@1.0.14

нпм ERR! Linux 4.2.8-1-pve

нпм ERR! argv "/ usr / bin / nodejs" "/ usr / bin / npm" "install" "chromedriver" "--chromedriver_cdnurl = http://npm.taobao.org/mirrors/chromedriver "

нпм ERR! узел v6.4.0

нпм ERR! npm v3.10.6

нпм ERR! код ELIFECYCLE

нпм ERR! chromedriver@2.23.1 install: узел install.js

нпм ERR! Статус выхода 1

нпм ERR!

нпм ERR! Не удалось выполнить в установочном скрипте chromedriver@2.23.1 «install.js».

нпм ERR! Убедитесь, что у вас установлена ​​последняя версия node.js и npm.

нпм ERR! Если вы это сделаете, это, скорее всего, проблема с пакетом chromedriver,

нпм ERR! не с самой нпм.

нпм ERR! Скажите автору, что это не работает в вашей системе:

нпм ERR! узел install.js

нпм ERR! Вы можете получить информацию о том, как открыть вопрос для этого проекта, с помощью:

нпм ERR! Npm Bugs Хромированный драйвер

нпм ERR! Или, если это не доступно, вы можете получить их информацию через:

нпм ERR! владелец npm ls chromedriver

нпм ERR! Вероятно, есть дополнительные выходные данные регистрации.

нпм ERR! Пожалуйста, включите следующий файл с любым запросом поддержки:

нпм ERR! /opt/slamdata/npm-debug.log

Автор: Ali Yousefi Sabzevar Источник Размещён: 08.11.2019 10:58

Ответы (1)


0 плюса

Я встретил его с помощью 'yarn install', информация о которой 'chromedriver: Сбой установки ChromeDriver Ошибка с http'. Так что я пытаюсь установить chromedriver до 'yarn install'. И тогда решите это.

https://www.npmjs.com/package/chromedriver

Автор: cc Aier Размещён: 04.12.2017 02:44
Вопросы из категории :
32x32