images not showing up in assistant editor of xcode

xcode-storyboard xcode7.3

97 просмотра

2 ответа

893 Репутация автора

I have created a new project in Xcode 7.3.1 and added images in device specific xcassets. When I open preview of storyboard in Assistant editor, I am not able to see the image in any screen size. If I choose universal, they start showing up. Same happens for iPad storyboard as well. Please see the attached screenshots and please help.

Above image is showing up in assistant editor because it is added in 1x and 2x of universal. The below image is not showing because of being added in device specific1

Автор: Swati Источник Размещён: 19.07.2016 09:03

Ответы (2)


0 плюса

3183 Репутация автора

I got the same problem as you today... I think this is a bug of Xcode, below is the way to fix the issue:

Close the project you are working on with. Delete your project's【DerivedData】folder.

This folder may inside your project's folder, or inside

~/Library/Developer/Xcode/DerivedData/(your project)/

or else run this in terminal

rm -rf ~/Library/Developer/Xcode/DerivedData

or somewhere else that was setup by you. restart your project. After these steps, the problem should be solved. And from my experience, these steps can solve many Xcode problems, so if you got some problem with Xcode again, try these steps first.

Автор: PinkeshGjr Размещён: 01.08.2016 05:58

0 плюса

449 Репутация автора

I guess this is related to XCode's internal workings to pick up the images. As the images (device specific) are not shown in the storyboard but they do show when you run the project either in Simulator or in device.

Автор: Manish Verma Размещён: 01.08.2016 06:43
Вопросы из категории :
32x32