C # DiffSharp v0.7.7 Ищем FSharp.Core v4.4.0.0

c# f# diffsharp

190 просмотра

1 ответ

21 Репутация автора

Я пытался использовать самую последнюю версию DiffSharp (v0.7.7) с C #. Я продолжаю получать следующую ошибку:

Ошибка 3 Сборка 'DiffSharp, Версия = 0.7.7.0, Культура = нейтральная, PublicKeyToken = null' использует 'FSharp.Core, Версия = 4.4.0.0, Культура = нейтральная, PublicKeyToken = b03f5f7f11d50a3a', которая имеет более высокую версию, чем указанная сборка 'FSharp .Core, версия = 4.3.0.0, культура = нейтральная, PublicKeyToken = b03f5f7f11d50a3a '

Кажется, ищет FSharp.Core версии 4.4.0.0. Насколько я знаю, такой вещи не существует. Или я не прав? Я использую Visual Studio 2012 на Windows 10 и обновил абсолютно все, что мог придумать. Моя сборка .Net 4.6.1.

Я попытался сделать это исправление, также упомянутое в Переполнении стека: не удалось загрузить файл или сборку FSharp.Core, версия = 4.0.0.0 веб-роль Azure

но это ничего не дало.

У кого-нибудь был подобный опыт, подобный этому?

Любые мысли / идеи / решения будут с благодарностью.

Автор: phoenix Источник Размещён: 19.07.2016 07:07

Ответы (1)


0 плюса

116 Репутация автора

Наткнулся на ту же проблему с diffSharp и C #. Я решил проблему, добавив пакет nuget FSharep.core в проект. Install-Package FSharp.Core-Версия 4.7.0

Автор: XS_iceman Размещён: 10.09.2019 01:30
32x32