Visual Studio 2015 Update 3 Installation/Change Fails - "The parameter is incorrect"

visual-studio visual-studio-2015 install

926 просмотра

2 ответа

8 Репутация автора

I am trying to install the Visual Studio 2015 Update 3, but I am receiving an error each time. I have tried both the web installer and the ISO, and I have also tried going into Control Panel/Programs and modifying the 2015 install. All of these result in the same error: "Setup Engine - The parameter is incorrect". I've read about some of the other issues with the installer, but I'm hoping somebody else might have seen this one or something similar. The logs always have the following error in them:

[1B10:1DA0][2016-07-18T11:39:28]e000: Error 0x80070057: Failed to convert version: to DWORD64 for ProductCode: {284FA9A0-CEDD-81D3-5A19-5858E95FD0C4}

[1B10:1DA0][2016-07-18T11:39:28]e151: Detect failed for package: Win10_Universal_CRT_SDK_Extension_SDK, error: 0x80070057

I have even tried to download the full installer for VS2015, but all installers seem to run through the same error. Any ideas on how I might repair this particular component so the installs will succeed?

Additional information, this is happening on a VM of Windows 10 running in Parallels 11.

Screen shot of installer failing

Автор: maestro509 Источник Размещён: 18.07.2016 03:48

Ответы (2)


1 плюс

3844 Репутация автора

Решение

I found a similar issue here: https://connect.microsoft.com/VisualStudio/feedback/details/974081/visual-studio-update-3-installation-keeps-failing-error-message-setup-engine-the-parameter-is-incorrect
The reply from Heath[MSFT]:

The logs confirm that some of your Windows Installer product registration is corrupt. For the first issue, open a command prompt (preferably elevated to avoid multiple UAC prompts later) and run the following:

start /wait msiexec /fomus {284FA9A0-CEDD-81D3-5A19-5858E95FD0C4} REINSTALL=ALL 

That should get you past the first problem. If it does not, manually remove the product like so and re-install it from the package cache:

start /wait msiexec /x {284FA9A0-CEDD-81D3-5A19-5858E95FD0C4} IGNOREDEPENDENCIES=ALL 
start /wait msiexec /i "C:\ProgramData\Package Cache\{A79F6653-6AF1-4AF2-BC15-F5D6C05E1E6A}v2.0.40326.0\packages\sptoolsDependencies\enu\WorkflowManagerTools_x64.msi" ADDLOCAL=ALL NOVSUI=1 

(change the above file WorkflowManagerTools_x64.msi according to your log file record) After this, installing VS Update 3 should work.

Автор: Sara Liu - MSFT Размещён: 19.07.2016 06:36

0 плюса

3 Репутация автора

I had a very similar problem which at its root exhibited the same issue identified above in the Visual Studio 2015 Update 3 setup error (I couldn't install SSMS 17.1 which uses the Visual Studio 2015 Isolated Shell). I tried the solution above which unfortunately did not work for me. I did some more digging through the vs_isoshell.exe log file and found lines similar to those below.

[6BE0:36E0][2017-07-13T13:05:36]i000: Error 0x80070057: Failed to convert version: to DWORD64 for ProductCode: {9A7E3828-17FB-3E0C-9B28-48493E01937A}

The ProductCode refers to the "Microsoft Visual C++ 15 x86 Debug Runtime - 14.10.24269".

A perusal of my installed programs showed I did not have this installed, and I was unable to install it again due to a later version being present (it turns out it was upgraded, or removed, when I installed Visual Studio 2017).

I did some more searching and came across this page which had steps I adapted to my situation. I performed the same registry profiling of the installer with Process Monitor and the same key was missing. I added a key called DisplayVersion (string - REG_SZ) to the path below with a value of 14.10.24629 and that worked.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\8283E7A9BF71C0E3B9828494E31039A7\InstallProperties]

Adding the key/value pair allowed the installation of the VS 2015 Update 3 Isolated Shell to finish successfully which in turn allowed the SSMS 17.1 installation to complete successfully.

Автор: J. Wynn Размещён: 14.07.2017 04:22
Вопросы из категории :
32x32