Jenkins hanging with building Maven job

java oracle maven jenkins oracle11g

518 просмотра

1 ответ

88 Репутация автора

I have a problem when I want to build my Maven project using Jenkins job. When I build my application locally, application gets built without problems. But when I run Jenkins job, it hangs like on the picture below:

Started by user anonymous
Building in workspace /root/.jenkins/workspace/project
Updating http://ipaddress:port/svn/trunk/project at revision '2016-07-18T08:22:15.365 -0500'

At revision 7872 
//it hangs loading here

I am using Maven 3.2.3 and Jenkins 1.588.

I didn't have any problems before, until I've changed connection strings in pom.xml for connection to the database. (datasource.url property in pom.xml is changed). I've upgraded version of Oracle from 11 to RAC 12, and I had to change connection strings in the format provided below:

<datasource.url>jdbc:oracle:thin:@aaa-bbb-scan.eeee-rs.local:1521/abdce</datasource.url>

When I run Jenkins job, he gets stuck and I can't find any error on any log file...I've checked Jenkins log files, tomcats log files, but nothing is shown. Job breaks before it parse POMs.

When I revert changes in datasource.url, I can build my application without problems. Previous connection string was in format provided below:

<datasource.url>jdbc:oracle:thin:@ipaddress:1521:abcde</datasource.url>

If anyone have some idea where to look for solution of the problem, please comment it.

Thanks in advance

Автор: Dejan Jankovic Источник Размещён: 18.07.2016 02:26

Ответы (1)


0 плюса

88 Репутация автора

Решение

The problem was in connection to our SVN servers.

It turns out that we didn't have any technical problems with building application through Jenkins.

Автор: Dejan Jankovic Размещён: 10.08.2016 07:22
Вопросы из категории :
32x32