Ошибка Gradle при импорте play-services-contextmanager

android build.gradle google-awareness

948 просмотра

3 ответа

15185 Репутация автора

Во время клонирования репозитория Aware в моей Android Studio синхронизировался Gradle, и я получил следующее сообщение:

Не удалось синхронизировать проект приложения "Gradle"

Ошибка: не удалось найти com.google.android.gms: play-services-contextmanager: 9.2.0. Требуется: Aware: приложение: не указано

compile 'com.google.android.gms:play-services-contextmanager:9.2.0' уже есть в моем build.gradle

Смотрите build.gradle:

apply plugin: 'com.android.application'
apply plugin: 'com.neenbedankt.android-apt'

android {

    compileSdkVersion 23
    buildToolsVersion "23.0.3"

    defaultConfig {
        applicationId "com.hitherejoe.aware"
        minSdkVersion 21
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.4.0'
    compile 'com.google.android.gms:play-services-contextmanager:9.2.0'
    compile 'com.android.support:design:23.0.1'

    compile 'com.jakewharton:butterknife:8.1.0'
    apt 'com.jakewharton:butterknife-compiler:8.1.0'
}

Нужна помощь для построения проекта. Кто-нибудь может сказать, что мне не хватает?

Автор: pRaNaY Источник Размещён: 18.07.2016 01:46

Ответы (3)


1 плюс

95001 Репутация автора

Последняя версия 9.2.1.

com.google.android.gms:play-services-contextmanager:9.2.1

https://developers.google.com/android/guides/setup

Автор: cricket_007 Размещён: 18.07.2016 01:55

0 плюса

111 Репутация автора

Вы должны загрузить сервисы Google Play в свою Android Studio с помощью SDK Manager.

Автор: gabodroid Размещён: 18.07.2016 01:58

6 плюса

1167 Репутация автора

Зависимость Awareness API была переименована в com.google.android.gms:play-services-awareness. Ваше заявление о компиляции должно быть следующим:

compile 'com.google.android.gms:play-services-awareness:9.6.1'
Автор: Ajith Pandian Размещён: 14.10.2016 05:10
Вопросы из категории :
32x32