IE Bootstrap шрифты (иконки) не загружены

twitter-bootstrap internet-explorer ssl load-balancing

2546 просмотра

2 ответа

989 Репутация автора

Internet Explorer 11 имеет проблемы с отображением значков начальной загрузки. С Opera, Firefox и Chrome он работает отлично, а также с Edge, но значки не отображаются с IE в режиме Edge или (10,9,8). До того, как я сменил сайт на https, все работало нормально. У меня есть эта проблема после изменения на ssl.

Кто-нибудь знает, что я могу сделать, чтобы решить эту проблему (на сервере - Microsoft Azure или на балансировщике нагрузки)?

С IE (значки не отображаются): IE

С Firefox:

введите описание изображения здесь

Автор: quma Источник Размещён: 18.07.2016 08:59

Ответы (2)


4 плюса

155 Репутация автора

Похоже, проблема с настройками безопасности или кэша -> проверьте эту ветку на возможное решение:

Начальная загрузка 3.2.0 глифы не отображаются в Internet Explorer

Автор: Canu667 Размещён: 22.07.2016 07:46

1 плюс

1453 Репутация автора

Spring-Boot генерирует недействительные кеш заголовки в HTTP-ответах:

Cache-Control :"no-cache, no-store, max-age=0, must-revalidate"

а также

pragma: "no-cache"

Решение состоит в том, чтобы скрыть эти заголовки в браузере.

Я использовал nginx в качестве прокси-сервера, добавив следующие команды в расположение прокси https:

  proxy_hide_header Cache-Control;
  proxy_hide_header Pragma; 

Подробности смотрите здесь с помощью nginx.

Используя apache httpd, синтаксис здесь

Автор: user1767316 Размещён: 29.03.2017 01:04
Вопросы из категории :
32x32