There was something wrong with my password. I got an error when installing phpMyAdmin

php mysql ubuntu phpmyadmin ubuntu-16.04

1384 просмотра

1 ответ

8 Репутация автора

The error is shown as a screenshot by clicking the link: The error box

What can I do?

The error in text is:

An error occurred while installing the database:
mysql said: mysql: [Warning] mysql: Empty value for 'port' specified. Will throw an error in future versions ERROR 1819 (HY000) at line 1: Your password does not satisfy the current policy requirements . Your options are: * abort - Causes the operation to fail; you will need to downgrade, reinstall, reconfigure this package, or otherwise manually intervene to continue using it. This will usually also impact your ability to install other packages until the installation failure is resolved. * retry - Prompts once more with all the configuration questions (including ones you may have missed due to the debconf priority setting) and makes another attempt at performing the operation. * retry (skip questions) - Immediately attempts the operation again, skipping all questions. This is normally useful only if you have solved the underlying problem since the time the error occurred. * ignore - Continues the operation ignoring dbconfig-common errors. This will usually leave this package without a functional database. Next step for database installation:

Автор: SuhDoo Источник Размещён: 18.07.2016 04:57

Ответы (1)


1 плюс

11 Репутация автора

Your password does not satisfy the current policy requirements - probably it's too weak. try this: sudo apt-get remove --purge phpmyadmin php-mbstring php-gettext && sudo apt-get install phpmyadmin php-mbstring php-gettext

then: when prompted again for a password choose one with special char, upper and lower char, and numbers..

hope it helps

Автор: tomatics Размещён: 05.10.2016 07:53
Вопросы из категории :
32x32