"The application does not have a valid signature" Xcode 4.3

iphone objective-c ios xcode xcode4.3

13685 просмотра

7 ответа

I'm getting the weirdest error today.

"The application does not have a valid signature"

I get this error when I try to run the application from Xcode 4.3 on my device. Also when I archive it shows it as a generic archive instead of a real app.

Of course I deleted all of the invalid profiles, cleaned my derived data, cleaned my target, and restarted. No luck.

EDIT: Turns out that I had a folder reference in my app. I removed all of the references to the folders and made them groups and it worked!

Автор: Matt Hudson Источник Размещён: 12.11.2019 09:41

Ответы (7)


28 плюса

Just throwing this out there, might help someone in the future (and also would be good for my future reference).

I have a bigger project with 2 projects within (an API and the main project that is running on the device itself and which uses the API).

I have solved this problem by cleaning both projects and then rebuilding them.

Автор: Andrei Размещён: 16.01.2013 03:22

5 плюса

Ohhh...Cleaning the Project solved my problem..cheers :)

Автор: Hawk-Eye Размещён: 25.01.2013 07:53

4 плюса

This saved me: http://www.two-tails.com/2010/01/12/the-application-does-not-have-a-valid-signature/

Basically you cannot have a folder reference called "resources"! I changed to "rsrc" and magic.

Автор: zerodog Размещён: 17.07.2013 11:13

1 плюс

You can get a more detailed error message in the device log, which is extremely valuable for debugging this issue.

In XCode 7.3: Window -> Devices -> Select your device -> At the bottom there is an error log with detailed information.

For example in my case it outputs something like this:

Failed to install application at file:///var/mobile/Media/PublicStaging ... : Error Domain=LaunchServicesError Code=0 "(null)" UserInfo={Error=ApplicationVerificationFailed, ErrorDetail=-402620391,
ErrorDescription=Failed to verify code signature of
/private/var/mobile/Library/Caches/com.apple.mobile.installd.staging/temp.iKT2NH/extracted/XYZ.app
/Frameworks/Raygun4iOS.framework : 0xe8008019 (The application does not have a valid signature.)}

So in my case it is somehow caused by the Raygun framework that I have installed.

Автор: robert Размещён: 14.04.2016 08:42

0 плюса

Решение

Turns out that I had a folder reference in my app. I removed all of the references to the folders and made them groups and it worked!

Автор: Matt Hudson Размещён: 15.10.2012 05:53

0 плюса

Also, make sure that when you go to Product > Scheme > Edit Scheme the Build Configuration is set to Running.

Автор: arik Размещён: 26.04.2013 08:00

0 плюса

I struggled with this for a few hours, but it seems that if you have a framework listed under "Embedded Binaries" as well as being imported through a swift bridging header, this error comes up. I am running XCode 8 with iOS 10. I would try removing your framework from the embedded binaries tab under general settings of your XCode projects. Hope this helps out some person in the future!

Автор: Spiritman110 Размещён: 26.06.2016 05:51
Вопросы из категории :
32x32